Do not use "Manager" or "Helper" or other null words in a type name.
If you need to add "Manager" of "Helper" to a type name, the type is either poorly named or poorly designed. Likely the latter.
I always agreed with this: names like
XmlHelper are too vague to be useful. But I never came up with a retort as pithy as this one of Robert Nystrom's:
Types should manage and help themselves.